[BM- SPSS 4th Math Class Evar Lutfalla Sadraddin

Transforming Data by Compute Action

In this "quick start" guide, we will enter some data and then perform a
transformation of the data. Transforming data is performed for a whole host of
different reasons. We show you how to transform your data using SPSS Statistics
for “square", "square root", "reflect and square root", "reflect and log",
"reciprocal", "reflect and inverse" and "log" transformations. Also, we apply a
transformation to data that is not normally distributed so that the new, transformed
data is normally distributed. Transforming a non-normal distribution into a normal
distribution is performed in a number of different ways depending on the original

distribution of data, but a common technique is to take the log of the data

Transforming Data- Compute in SPSS Statistics

Click on Transform > Compute Variable... in the top menu, as shown below:
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You need to first select the function you would like to use. To do this, click "All" in
the Function group: bOX or you can write a mathematics expression to transform the given
data into the required form. In the Target Variable, write the name of the new variable

and also you can make a new label and type.

LG 10(numexpr). Numeric. Returns the base-10 logarithm of
numexpr, which must be numeric and greater than 0

(optional case selection condition)

] Compute Variable
Target Variable Numeric Expression
Moata | - [Loi0mats)
Type & Label...
& Data +
Function group
+ <
Arithmetic
E] CDF & Noncenral CDF
=
Conversion
E] E] Current Date/Time
Date Arithmetic
E] Date Creation =
. Functions and Special Variables:
&) = =
Lag(1) <

Lag(2)
Length
Lgio

Ln
Lngamma
Lower
Ltrim(1)
Ltrim(2)
Wax

Mblen.Byte

The result will be new variable in new column as follows
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Data TrData v
1 36.00 1.56
2 32.00 1.5
3 45.00 1.65
4 41.00 1.61
5 29.00 1.46
B 2200 1.34
7 16.00 1.26
B 36.00 1.56
9 10.00 1.00
10 40.00 1.60
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Recoding Variables

The instructions below will show you how to recode variables. You can use
recoding to produce different values or codes for a variable. Recoding can be done

in one of two ways:

e Recoding into the same variable
e Recoding into a different variable

In this guide, we will concentrate on recoding into a different variable, for which

there are 3 main types of recoding:

e Recode single values
e Recode a given range of values
e Recode data into two categories

Recoding Variables in SPSS Statistics

Click on Transform > Recode Into Different VVariables

aSet0] - PASW Statistics Data Editor,

Data Transform  Analyze  Graphs  Utilties  Add-ons
!J E Egompute\#ariahle... ﬂ

E Count Walues within Cazes.

Shift Walues... -

uns
a5

1200 =
e E Automatic Recode.

E Recods into Same Yariakles..

E Recods into Different Yariakles..

10 HPE Wisual Binning...

1a. E:E Fank Cazes...
% Date ancd Time Wizard..
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We have to write down the new name and label for the new variable as below, then
click change to get it.

$:t Recode into Different Variables

Mumeric Variahle -= Output Yariable: —Cutout Variable
Rung --= 7
Mame:
’ RankedRuns
Label:
Fanked Runs
ﬁ
/
Old and Newr Values...
(c-ptional caze selection condtion)
Pazte [ Reset ] [Cancel ] [ Help ]

And, in Old and New values, we get a box to change old values into single value
or we can use a range of data and transform them into new categorical data. A
good example about this, if we have continues variable like AGE and we want to
conduct a categorical analysis; we can recode it into many categories using ranges.

This is a single recode.

$if Recode into Different Variables: Old and Mew Values

Ol Value Menw Yalue
@ Walue: @ Walue: |1 |

|1 20 (i8] System-missing
@ System-misszing @ Copy old M
© System- aor user-missing
© Range: /Olg =DIISE

through Add

Change

@ Range, LOWWEST through value: Remave

(i8] Range, value through HIGHEST:

[ ooutpt variahles are strings Wlictth: 5

@ 2 other walues H Convert numetic strings to numbers ('5'-=5)

[Corrtinue” Cancel ” Help ]
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The range recodes,

i3t Recode into Different Variables: Old and New Values

e Yalue Teleen ' alue
© Walue: @ Walle: |1| |

@) system-missing

(@] Copy old valuers)

© System-missing

(@) System- or user-mizzing
@ Range:
thraugh Add
100
© Range, LOWWEST through walus:

Cld = Mew:

(@)} Range, value through HIGHEST:

|:| Cutput variakles are strings
@) Al other values

[Continue” Cancel ” Helg ]

Continue adding and making categories

%8t Recode into Different Yariahles: Old and New Values

rCld Yalue

“alue:

System-missing
System- ar user-missing
@ Ranoe:

I

thraugh

I

All gther walues

TMew Yalue

@ Walue: |

System-mizsing
Copy old value(s)

Range, LOWEST through value:

Range, value through HIGHEST:

Ol --= Memw:

7S thru 100 --=1
B1 thru 74 = 2
4 thru B0 --= 3
Othru 40 --= 4

D Output variables are strings

[Continue][ Cancel ][ Helg ]

Then click, continue to get the result.

Select Cases form Data Set
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You rarely want to remove/delete data from your SPSS Statistics file, but there are
a number of occasions when you need to filter that data before analysing it (e.g., to
take into account missing data or outliers in your data set that could be negatively
affecting your results). We show you, step-by-step, how to select different types of
data (i.e., specific cases) and then filter your data set.

Select Cases function in SPSS Statistics.

Click Data > Select Cases ... on the main menu as shown below

1ss_tutornial_set1.sav [DataSet2] - IBM SPSS Statistics Data Editor

Edit View Data Transform Analyze Graphs |Uliliies Exensions

ﬁ L3, | 7 Define Variable Properties... I AR |
i =3 e |

| 2 SetMeasurement Level for Unknown...
||z CopyData Properties... | —
_ | 2od g | var
= Define date and time...
EE Define Multiple Response Sets...
Validation > |
E= Identify Duplicate Cases...
F7 Identify Unusual Cases...
T Compare Datasets...
= SortCases...
ES Sort Variables...
| =2 Transpose...
Merge Files L
EE Restructure...
&1 Aggregate...
Orthogonal Design »
i T Copy Dataset
! == SplitEile...
&5 selectCases...

&} Weight Cases...

The Functions for expression dialog allows you to select subsets of cases using
conditional expressions. A conditional expression returns a value of true, false,
or missing for each case.

e |If the result of a conditional expression is true, the case is included in the
selected subset.
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o If the result of a conditional expression is false or missing, the case is not
included in the selected subset.

Q Select Cases X
-Select
& Time ElapsedBefor.. | = © All cases
@ Se{( [Sex] | | @ ifcondition is satisfied
& Height (Inches) [Hei... ) Click I

' © Random sample of cases
© Based on time or case range

Use filter variable:
% |

- Qutput
Filter out unselected cases
©) Copy selected cases to a new dataset

© Delete unselected cases

Current Status: Do not filter cases

[ Reset J LC,_ancel,.] [ Help ]

Most conditional expressions use one or more of the six relational operators (<, >,
<=, >=, =, and ~=) on the calculator pad.

Conditional expressions can include variable names, constants, arithmetic
operators, numeric (and other) functions, logical variables, and relational operators.
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@ *spss_tutorial_set1.sav [DataSet2] - IBM SPSS Statistics Data Editor - (] X
File Edit View Data Transform Analyze Graphs Utilities Extensions Window Help
FHe M e~ BHLAE H B .96
[z: | |Visible: 4 of 4 variables
& Duration | @ Sex | & Height & filter var | vt | var | var |
1 5.50 Female 66 Selected
550 Male 66, Not Selected
3 5.51 Female 67 Selected
4 551 Female 68 Selected
5 6.26 Female 62 Selected
6 6.26 Female 70 Selected
71 Male 61|  Not Selected
711 Male 64|  Not Selected
9 209  Female 75 Selected
294 Male 65|  Not Selected ' ' '
324 Male| 71| Not Selected ' ' 10
12 3.86/ Female 67 Selected
398 Male: 68|  Not Selected
415 Male gl Not Selected
15 418 Female 7 Selected
16 433 Female 67 Selected
17 441 Female 65 Selected
18 470 Female 65 Selected
4388 Male 73| Not Selected
5.09 Male 71| Not Selected =
¥
[ |IBM SPSS Statistics Processoris ready| | |Unicode:ON|Filteron| |
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Spearman’s Rank-Order Correlation

The Spearman rank-order correlation coefficient (Spearman’s correlation, for
short) is a nonparametric measure of the strength and direction of association that
exists between two variables measured on at least an ordinal scale.

For example, you could use a Spearman’s correlation to understand whether there
IS an association between exam performance and time spent revising; whether there
IS an association between depression and length of unemployment; and so forth.

Spearman'’s correlation analysis in SPSS Statistics

Click Analyze > Correlate > Bivariate... on the main menu as shown below:

5= spearman-correlation-te
File Edit View Data Transform Analyze Graphs Utilittes Add-ons Window Help

SEE @M ] B hEE

Descriptive Statistics

Compare Means [

English_Mark | Math General Lingar Model ~ » var var

56 Generalized Linear Modelse

75 Mixed Models
45

m
61
64
58
80
76
61

Correlate [ Bivariate...

[&] Partial...

[ Distances...

3

2

Regression 2
Loglinear »
Classify b
Dimension Reduction »
2

2

3

2

P

Scale

(T=T == T R = - RS 5 B AR PR T

Monparametric Tests

—
=

Forecasting

-
==

Survival

13 Multiple Response

14 % Simulation...

15 Quality Control }
16 ROC Curve...

You will be presented with the Bivariate Correlations dialogue box:
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Select the Spearman checkbox in the —Correlation Coefficients— area. You will
end up with a screen similar to below:

ta Bivariate Correlations “
Variables:
= Options...

& English_Mark
& Maths_Mark

Correlation Coefficients

[T Pearson [] Kendall's tau-b -/g

Test of Significance
@ Two-tailed © One-tailed

[ Flag significant correlations

[ oK ][ Paste ][ Reset ][Cancel][ Help ]

Therefore, after running the Spearman’s correlation procedure, you will be
presented with the Correlations table, as shown below:

Correlations

Englizh_Marlk | Maths_Mark
Spearman's rho English_Mmark  Correlation Coefficient 1.000 BRY
Sig. (2-tailed) ) 035
i 10 10
haths_Mark Correlation Coefficient 669 1.000

Sig. (2-tailed) n3s |
I 10 10

* Correlation is significant at the 0.05 level (2-tailed).

The Correlations table presents Spearman’s correlation, its significance
value (i.e., p-value) and the sample size that the calculation was based on.

In this example, the sample size, N, is 10, Spearman's correlation coefficient, rs,
Is 0.669, which is statistically significant (p = .035).
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Reporting the results of a Spearman’s correlation analysis

A Spearman's rank-order correlation was run to determine the relationship
between 10 students' English and maths exam marks. There was a strong, positive
correlation between English and maths marks, which was statistically significant
(rs(8) = .669, p = .035).

Linear Regression Analysis using SPSS Statistics

Linear regression is the next step up after correlation. It is used when we want to
predict the value of a variable based on the value of another variable. The variable
we want to predict is called the dependent variable (or sometimes, the outcome
variable). The variable we are using to predict the other variable's value is called
the independent variable (or sometimes, the predictor variable). For example, you
could use linear regression to understand whether exam performance can be
predicted based on revision time; whether cigarette consumption can be predicted
based on smoking duration; and so forth.

Linear Regression in SPSS Statistics

Click Analyze > Regression > Linear... on the top menu,

ta linear regression.sav [DataSet2] - IBM SPSS Statistic
File Edit View Data Transform Analyze Graphs Utiliies Add-ons Window Help

SHe @ | " 'E M # e B S|

Descriptive Statistics

Compare Means »

Income Price General Linear Model » var var var

Generalized Linear Modelsh

Mixed Models 2

Correlate

Regression E_Aummatic Linear Modeling

oo & |le|fraff =

Laglinear
Classify

Dimension Reduction

\:inear.. %
[ curve Estimation
E Partial Least Squares..
[ Binary Logistic...
E Multinomial Logistic...
[ ordinal
12
EEFUDIL..
13
14 % Simulation. E Monlinear..
15 Quality Control 2 [iid weignht Estimation
16 ROC Curve... g—Stage Least Squares...

Scale
Monparametric Tests

Forecastin
1 =1

Survival

Multiple Response
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You will be presented with the Linear Regression dialogue box, then Transfer the

independent variable into the Independent(s): box and the dependent variable into
the Dependent: box.

ta Linear Regression u
Dependent: m
& e » |§ - |
Block 1 of 1 | Pots.. |
-nge...
# (optors. |
= Opti
Independent{s):
& Income
Method: |Enter =
Selection Variable:
=2 | |
Case Labels:
= |
WLS Weight:
e |
[ OK ][ Paste ][ Reset ][Cancel][ Help ]

Output of Linear Regression Analysis

The first table is the Model Summary table, as shown below:

Model Summary

Adjusted R atd. Errar of
Model K R Sguare sguare the Estimate
1 ar3d T62 748 87477y

a. Predictors: (Constant), Income

This table provides the R and R?values. The R value represents the simple
correlation and is 0.873 (the "R" Column), which indicates a high degree of
correlation. The R2 value (the "R Square” column) indicates how much of the
total variation in the dependent variable, Price, can be explained by the
independent variable, Income. In this case, 76.2% can be explained, which is very
large.

The next table is the ANOVA table, which reports how well the regression
equation fits the data (i.e., predicts the dependent variable) and is shown below:
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ANOVA®
Sum of
Madel Squares df Mean Square F Sig.
1 Regression 44182633.37 1 44182633.37 AT.7T3T .0on®
Residual 13774291.07 18 TER238.393
Total ETORE924 .44 14

a. DependentYariable: Price
b. Predictors: (Constant), Income

This table indicates that the regression model predicts the dependent variable
significantly well. How do we know this? Look at the "Regression™ row and go to
the "Sig." column. This indicates the statistical significance of the regression
model that was run. Here, p < 0.0005, which is less than 0.05, and indicates that,
overall, the regression model statistically significantly predicts the outcome
variable (i.e., it is a good fit for the data).

The Coefficients table provides us with the necessary information to predict price
from income, as well as determine whether income contributes statistically
significantly to the model (by looking at the "Sig." column). Furthermore, we can
use the values in the "B" column under the "Unstandardized Coefficients"
column, as shown below:

Coefficients®
Standardized
Unstandardized Coefficients Coefficients
Model B Std. Error Beta 1 Sig.
1 (Constant) B2B6.786 1852.256 4.474 .000
Income G644 .074 873 7.598 .0oo

a. DependentVariable: Price

To present the regression equation as:

Price = 8287 + 0.564(Income)
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