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Geometric	Construction	Steps	
  

After launching the CST STUDIO SUITE you will enter the start screen showing you a list of recently 
opened projects and allowing you to specify the application which suits your requirements best. The 
easiest way to get started is to configure a project template which sets the basic settings that are 

meaningful for your typical application. Therefore click on the New Template  button in the New Project 
from Template section. 
  
Next you should chose the application area, which is Statics and Low Frequency for the example in this 
tutorial and then select the workflow High Voltage / Heavy Current by double-clicking on the 
corresponding entry. 
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For the circuit breaker, please select High Voltage / Heavy Current > Vacuum 

Interrupters/Switchgears/Circuit-Loadbreakers >  Stationary Current . 
  

At last you are requested to select the units which fit your application best. The circuit breaker device in 
this tutorial has dimensions given in cm. Therefore select cm from the Dimensions drop-down list if not 
already set. For the specific application in this tutorial,  the other settings can be left unchanged. After 
clicking the Next button, you can give the project template a name and review a summary of your initial 
settings. 
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Finally, click the Finish button to save the project template and to create a new project with appropriate 
settings. CST EM STUDIO will be launched automatically due to the choice of the application area Statics 
and Low Frequency. 
  
Please note: When you click again on File: New and Recent you will see that the recently defined 
template appears below the Project Templates section. For further projects in the same application area 
you can simply click on this template entry to launch CST EM STUDIO with useful basic settings. It is not 
necessary to define a new template each time. You are now able to start the software with reasonable 
initial settings quickly with just one click on the corresponding template. 
  
Please note: All settings made for a project template can be modified later on during the construction of 

your model. For example, the units can be modified in the units dialog box (Home: Settings > Units ) 
and the solver type can be selected in the Home: Simulation > Setup Solver drop-down list. 
  

  

Define background properties 

Once you have entered the modeling view, the background properties should be adjusted. Because the 
structure will be defined in a vacuum background, you must define the size of the surrounding empty 

space. Therefore, select Modeling: Materials > Background  to open the Background 
Properties dialog box. The Material type has been set to Normal already by the project template. Please 
deactivate the Apply in all directions checkbox, enter 0 cm for Lower X and Upper X distance as well as 2 
cm for the Lower Y, Upper Y, Lower Z and  Upper Z distance. No space is added for X-distances because 
the circuit breaker needs to touch the boundaries in order to apply the current port sources correctly in a 
later step, where the current distribution is used as source for a magnetostatic simulation. Now confirm by 
pressing the OK button. 
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Define the right contact 

The first step for the circuit breaker is the construction of the right contact which uses the trace function 

of a curve. Therefore, define the a line (Modeling: Curves > Curves > Line ) with 
1. first point at X = 5, Y = 2 and 
2. second point at X = 2, Y = 2. 

You can do this by clicking at the corresponding coordinates in the main view or by pressing 
the Tab or Esc key and enter the coordinates numerically. 
  

The next part of the curve is an arc. Select Modeling: Curves > Curves > Arc  and define 
1. the arc center at X = 2, Y = 1; 
2. start point at X1 = 2, Y1 = 0; 
3. end point at  X2 = 2, Y2 = 2. 
4. deactivate the "Edit angle" field. 

Check your settings against the screenshots below and verify that the arc is oriented correctly (otherwise 
you can change the arc's orientation in the dialog box). Finally, confirm with OK. 
  

 

 

  
The last curve element is another line and can be created similar to the first one. Activate the curve line 

tool (Modeling: Curves > Curves > Line ) and enter the points X = 2, Y = 0 and X = 3, Y = 0. The 
screenshot below shows the current model status: 
  

 
  
Finally, the curve has to be transformed into a solid to model the contact. The right tool for this procedure 

is the Trace from Curve tool. Select Modeling: Curves > Curve Tools > Trace from Curve  and 
double-click on any curve element when asked for the curve. Before you confirm the trace creation, a new 
material must be defined. Select [New Material...] from the Material drop down list in the trace definition 
dialog box and define the material copper. This requires changing the Material Name to copper, selecting 
a new color and inputting an electric conductivity of 5.8e7 S/m in the Conductivity tab. 
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Please note: The defined material copper will be available inside the current project for the further 
creation of other solids. However, if you want to save this specific material definition for use in other 
projects, you may check the button Add to material library. You will have access to this material database 
by clicking on Load from Material Library in the Materials context menu in the navigation tree. 
  
Pressing the OK button stores the material and closes the dialog box so that you can continue to enter the 
trace parameters. Back in the trace creation dialog box, please check that the Material has changed to 
copper. Enter contact spring in the Name field. Furthermore, 

1. define Thickness = 1, Width  = 0.2 
2. and Rounded Caps at the End. 

Please note that the end of the curve depends on which part of the curve you chose for the trace action. 
This fact must be considered in the construction, so you should ensure that the preview of the shape has 
a rounded cap at the shorter end. If not, it is only necessary to switch off the Rounded caps at 
the End and enable them at the Start of the curve. 
  

 

 

  

Define the contact pad 

To complete the construction of the right contact, the definition of a contact pad is still required. This task 
is easily done by extruding the bottom face of the spring. 
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To perform the extrusion, the desired face must be chosen beforehand. Therefore, activate the pick face 

tool with the shortcut f or via Modeling: Picks > Picks  and double-click on the bottom face of the 

spring. Then select Modeling: Shapes > Extrude  that opens a dialog box for the extrusion 
parameters. First, a new material has to be defined because the contact pad is composed of gold. 
Choose [New Material...]from the Material drop down list. In the New Material Parameters dialog box 

1. change the Material name to gold, 
2. set the Type to Normal, 
3. select a new color, 
4. input an Electric conductivity of 4.5e7 S/m in the Conductivity Tab, 
5. and store the material by pressing the OK button. 

 

 

  
Back in the Extrude Face dialog box, enter a name for the solid (contact pad) and 0.1 for the Height; the 
other parameters can be left at their default values. Verify your settings by pressing the Preview button 
and finally close the dialog box by pressing the OK button. 
  

 

 

  

Generation of the left contact by transformation 

Due to the symmetry of the structure, the left contact can be produced by just one mirror operation. 
Therefore, select component1 (which contains the contact pad as well as the contact spring) in the 
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navigation tree and choose Transform from the context menu or from the 

ribbon Modeling: Tools > Transform . In order to mirror the structure correctly, 
select Mirror as Operation, X = 1, Y = 0 and Z = 0 as the Mirror plane normal and activate 
the Copy option: 
  

 

 

  
After confirming with OK, two new shapes will appear in the navigation tree named as the transformation 
originals with _1 added. 
  

Define the pads of the bridge 

After modeling the contact, the pads of the bridge must be constructed. Therefore, pick the previously 
defined pad (contact pad) of the contact at the bottom and extrude it again. 
  

 
  

First, select Modeling: Picks > Picks  (shortcut: f) and double-click on the bottom face. Then activate 

the extrude tool (Modeling: Shapes > Extrude ) and enter 
1. a Name (bridge pad), 
2. a value of 0.1 for the Height and 
3. choose [New Component...] from the Component drop down list. 

In view of the fact that the bridge is physically independent, it is preferable to construct it as a new 
component; this makes it subsequently easier to manipulate, e.g. for transformations. 
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Again, check your settings and confirm with OK. 
  

Transform the pad 

As previously carried out for the contact, the bridge's pad on the left side can be created with a mirror 
operation. This requires the newly created pad to be selected by double-clicking on it. Then 
select Transformfrom the context menu to start the transformation and repeat the previously made steps: 

1. Select Mirror as Operation, 
2. set the Mirror plane normal to X=1, Y=0, Z=0 and 
3. activate the Copy option. 

Construction of the bridge 

The last modeling step is the construction of the bridge. Up to this point, the construction has been 
performed in the global coordinate system, because no relative construction was needed. For proper 
positioning,  it is advisable to define the bridge using a working coordinate system (WCS) that introduces a 
local coordinate system. For this tutorial, the WCS will be aligned in the middle of the bridge pads. 
  

 
  

The working coordinate system can be switched on or off by selecting Modeling: WCS > Local WCS . 
It can be aligned with a point (or any other object) with Align WCS (shortcut: w) which can be found 

under  Modeling: WCS > Align WCS  as well. For the bridge construction, 

1. activate the WCS (Modeling: WCS > Local WCS ), 

2. pick the two illustrated points (Modeling: Picks > Picks , shortcut: p), 
3. generate a new point with Modeling: Picks > Pick Point > Mean Last Two Points 

4. and align the WCS to this point (Modeling: WCS > Align WCS ). 
With the WCS in the right location it is now quite easy to define the bridge. Therefore, 

select Modeling: Shapes > Brick  to activate the Brick tool  and use the Tab key or double-click in the 
working plane to enter 

1. the first point at U = 4, V = 0, 
2. the second point at U = -4, V = -0.2, 
3. and -1 for the height. 

In the Brick dialog box you only have to enter a proper Name, e.g. bridge, and choose copper from 
the Material drop-down list. 
  

 

  

  
Now, the geometric modeling is complete and the solver settings have to be established. 
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Solver	Settings	
  

Define Boundary Conditions and Symmetry Settings 

The calculation domain is bounded by six faces. A boundary condition must be assigned to each of these 

faces. Open the Boundary Conditions dialog box by selecting Simulation: Settings > Boundaries . For 
this example, all boundaries need to be of type tangential. This fact is important for the subsequent 
magnetostatic calculation, because it means that the magnetic flux has only tangential (i.e. no normal) 
components at the boundaries. For the stationary current problem, the current ports force the boundary 
conditions locally to be normal, which means that the current field has only normal components at the 
current ports. Thus activate the Apply in all directions checkbox and choose tangential e, h or j from 
the Type drop-down list. 
  

 
figure 3 

  
Next, you may define a symmetry condition for the XY plane. This will reduce the problem size by a factor 
of 2, so symmetry conditions should always be defined, if possible. Because currents and electric fields will 
be tangential and magnetic fields will be normal to the XY plane, you should select a magnetic symmetry 
plane inside the Symmetry Planes tab. Finally confirm with OK. 
  

 

 

  
Please note: In particular, for coupled problems between the stationary current solver and the 
magnetostatic solver, normal and tangential symmetry planes are not recommended. Instead, the electric 
and magnetic symmetry planes should be used. They correspond to a Perfect Electric Conductor (PEC) for 
the electric boundary condition and a Perfect Magnetic Conductor (PMC) in case of the magnetic boundary 
condition. 
  

Definition of the current ports 

Before the solver can be started, the driving sources need to be defined. In this tutorial, two current ports 
on the faces of the contact springs are necessary to feed the structure with a homogeneous distributed 
current density. Enter the current port definition mode (Simulation: Sources and Loads > Current 
Port ) and click on the right face at the upper X-boundary (face#1). 
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Once the position is defined via the face pick, the dialog opens and the current value of the port is 
requested. Enter the value 500 for the Current of the first port, check the Invert current direction box and 
confirm with OK. Then enter the current port definition mode again and pick face #2 at the lower X-
boundary in order to define the second port. Enter the same Current value of 500 for this port, but keep 
the current direction unchanged: 
  

 

 

  
Both faces are highlighted with colors corresponding to the current values, when the Current ports folder 
in the navigation tree is selected. The arrows represent the current direction. 
  

Adjust Mesh Properties 

Before starting the solver, let's have a look at the mesh used for the calculation. In this tutorial we will 
employ the tetrahedral solver. Please note that the steps to employ the hexahedral solver are completely 
identical. To keep this tutorial short, we will restrict the workflow description of the coupled simulation to 
the tetrahedral solver and refer to the CST EM STUDIO Workflow & Solver Overview manual for more 
details on the hexahedral solver. 
  
By default, the tetrahedral mesh type is selected. So open the Mesh Properties - Tetrahedral dialog by 

clicking Simulation: Mesh > Global Properties . The project template should have set the Cells per 
max model box edge values to 10 for the Model and 5 for the Background. Click OK to confirm 
the Tetrahedral mesh settings and close the dialog box. Now activate the mesh view 

via Simulation: Mesh > Mesh View  and generate the mesh by clicking Mesh: Mesh 
Control > Update . Apparently, the default mesh is quite coarse: 
  

 
  


