
Q1/ Computers work through an interaction of hardware and software. what are mean that and  

What is Computer? define it. What can do with computers? 

 

solution: 

Computers are machines that perform tasks or calculations according to a set of instructions, or 

programs. The first fully electronic computers, introduced in the 1940s, were huge machines 

that required teams of people to operate. Compared to those early machines, today's computers 

are amazing. Not only are they thousands of times faster, they can fit on your desk, on your lap, 

or even in your pocket. Computers work through an interaction of hardware and software. 

Hardware refers to the parts of a computer that you can see and touch, including the case and 

everything inside it. The most important piece of hardware is a tiny rectangular chip inside your 

computer called the Central Processing Unit (CPU), or microprocessor. It's the "brain" of your 

computer—the part that translates instructions and performs calculations. Hardware items such 

as your monitor, keyboard, mouse, printer, and other components are often called hardware 

devices, or devices. 

 

Software refers to the instructions, or programs, that tell the hardware what to do. A word 

processing program that you can use to write letters on your computer is a type of software. The 

operating system (OS) is software that manages the computer and the devices connected to it. 

Windows is a well-known operating system. 

What can do with computers? 

In the workplace, many people use computers to keep records, analyze data, do research, and 

manage projects. At home, you can use computers to find information, store pictures and music, 

track finances, play games, and communicate with others—and those are just a few of the 

possibilities.  You can also use your computer to connect to the Internet, a network that links 

computers around the world. Internet access is available for a monthly fee in most urban areas, 

and increasingly, in less populated areas. With Internet access, you can communicate with 

people all over the world and find a vast amount of information.  Here are some of the most 

popular things to do with computers: the web, E-mail, Instant messaging, Pictures, music, 

movies, and gaming. 

 

Q2/ What is input / output devices?   Describe one input device and one output device in detail. 

 



 
 

 
 



 
 

 
 

Q3/ What is the difference between RAM and ROM? 

 

Difference between RAM and ROM RAM is Random Access Memory, 



while ROM stands for Read Only Memory. RAM is volatile and is erased when the computer is 

switched off. ... RAM is used for both read and write while ROM is used 

only for reading. RAM needs electricity to flow to retain information while ROM is permanent. 

 

Q4/ How we can insert table in word document?  

 

Click the New File icon to create a new document if necessary. To Create a table:  

1) Select the Table Menu  

2) Select Insert 

3) Choose Table  

4) Select 3 for the number of columns and 2 for the number of rows 

5) Click OK 

 

Q5/ Describe list table ways to navigate in an active document using keyboard to move the 

insertion point: 

 
 

Q6/ What are the main parts of MS power point window? How can working with different 

views in PowerPoint? 

 

Overview Pane- appears on the right side of the program windows and has to tabs 

 

Notes Pane: appears below the slide pane and provides a place for entering notes about the  

current slides (e.g, speaker notes) 

 These notes do not appear on the screen when the slides are shown in full screen mode  



 You can print notes along with your slides to creat a set of notes pages to which you can refer 

during your presentation. 

 

Slide tape 

 Main section in PowerPoint program  

 Shows the current slide as it will appear in a presentation 

 Displays a large image of the active slide in PowerPoint 

 In this section you can edit the slide constants  

 Display one slide at a time 

 

Working in Different Views  

 Normal View-Default View-you can add graphics to your slides as well as type, edit and 

format text. Add Animation; Edit Objects  

 Slide Sorter-Displays Multiple Slides-you can perform tasks such as reordering slides and 

adding builds, transitions, and slide timings for electronic presentations. -Slide Transitions; 

Hide slides. 

 

 Notes Pages View-You can create pages to print and use as a guide during your presentation.  

 Reading View-In this new view, the status bar contains the Next and Previous buttons, which  

are used to navigate quickly throughout the presentation, and the Menu button, which is used to 

print, copy, and edit slides. You can change your views under the View tab,  in the Presentation 

Views group. 

 

Q7/ What do you mean by cell address? How can you wrap the text within a cell? 

The cell address of an Excel sheet refers to the address that is obtained by the combination of 

the Row number and the Column alphabet. Each cell of an MS Excel sheet will have a distinct 

cell address. You must select the text you want to wrap, and then click wrap text from the home 

tab and you can wrap the text within a cell. 

 
 

Q8/ how can Working with Sheets tab 

A  worksheet is a collection of cells where you keep and manipulate the data. By default, each 

Excel workbook contains three worksheets. 

 

Select a Worksheet 

When you open Excel ,Excel automatically selects Sheet1 for you. The name of the worksheet  

appears on its sheet tab at the bottom of the document window. 

 

 



To select one of the other two worksheets, simply click on the sheet tab of Sheet2 or Sheet3. 

  

Rename a Worksheet 

By default, the worksheets are named Sheet1, Sheet2  and Sheet3. To give a worksheet a more 

specific name, execute the following steps .  

1. Right click on the sheet tab of Sheet1. 

2. Choose Rename. 

3.  For example, type Sales 2013 

Insert a Worksheet 

You can insert as many worksheets as you want. To quickly insert a new worksheet ,click the 

Insert  Worksheet tab at the bottom of the document window. 

Move a Worksheet  

To move a worksheet, click on the sheet tab of the worksheet you want to move and drag it into 

the new position .  

1 . For example, click on the sheet tab of Sheet4 and drag it before Sheet2.  

 

Delete a Worksheet  

To delete a worksheet, right click on a sheet tab and choose Delete. 

1. For example, delete Sheet4, Sheet2 and Sheet3. 

 

 

Copy a Worksheet 

Imagine, you have got the sales for 2013 ready and  want to create the exact same sheet for 

2011, but with different data. You can recreate the worksheet, but this is time-consuming. It's a 

lot easier to copy the entire worksheet and only change the numbers.  

1. Right click on the sheet tab of Sales 2013. 

2. Choose Move or Copy... 

3.  Select (move to end) and check Create a copy. 

4.  Click OK. 

 

Q9/ Computers range in size and capability. Describe the various kinds of personal computers 

(explain one of them in detail). 

answer: 

Desktop computers 

Desktop computers are designed for use at a desk or table. They are typically larger and  more 

powerful than other types of personal computers. Desktop computers are made up of separate 

components. The main component, called the system unit, is usually a rectangular case that sits 

on or underneath a desk. Other components, such as the monitor, mouse, and keyboard, connect 

to the system unit. 



Laptop computers and small notebook PCs 

Laptop computers are lightweight mobile PCs with a thin screen. Laptops can operate on 

batteries, so you can take them anywhere. Unlike desktops, laptops combine the CPU, screen, 

and keyboard in a single case. The screen folds down onto the keyboard when not in use. Small 

notebook PCs (often referred to as mini-notebooks), are small, affordable laptops that are 

designed to perform a limited number of tasks. They're usually less powerful than a laptop, so 

they're used mainly to browse the web and check e-mail. 

Smart phones 

Smart phones are mobile phones that have some of the same capabilities as a computer. You 

can use a smart phone to make telephone calls, access the Internet, organize contact 

information, send e-mail and text messages, play games, and take pictures. Smart phones 

usually have a keyboard and a large screen. 

Handheld computers 

Handheld computers, also called personal digital assistants (PDAs), are battery-powered 

computers small enough to carry almost anywhere. Although not as powerful as desktops or 

laptops, handheld computers are useful for scheduling appointments, storing addresses and 

phone numbers, and playing games. Some have more advanced capabilities, such as making 

telephone calls or accessing the Internet. Instead of keyboards, handheld computers have touch 

screens that you use with your finger or a stylus (a pen-shaped pointing tool). 

Tablet PCs 

Tablet PCs are mobile PCs that combine features of laptops and handheld computers. Like 

laptops, they're powerful and have a built-in screen. Like handheld computers, they allow you 

to write notes or draw pictures on the screen, usually with a tablet pen (the pen that come with 

table and is used to interact with items in the screen) instead of a stylus. They can also convert 

your handwriting into typed text. Some Tablet PCs are  “convertibles” with a screen that 

swivels and unfolds to reveal a keyboard underneath. 

 

Q10/  What mean Central Processing Unit. explain its units in detail. 

Central Processing Unit (CPU): the main circuit chip in computer, it performs most of  the 

calculations necessary to run computer.CPU speed measured by account of instructions that can 

execute in one secant, usually measured in (MHz). CPU contents two units:  

1. Control Unit (CU). 

2. Arithmetic and Logic Unit (ALU).  

 

1. Control Unit (CU). 

This unit control or supervised to all parts of computers such as:  

• Control operation of transfers data and instruction from input unit to memory and from 

memory to output unit.  

• Control operation of account executable instructions on ALU. 



• Basic work of CU is interpreter the instructions that is mean data oriented to specific location 

on ALU. for example: if the instruction is (B+C) the B,C values transfers to (Adder) part, if the 

instruction is (BxC) the B,C values transfers to (Multiplier) part, 

2. Arithmetic and Logic Unit (ALU). 

This unit execute the following operations:  

• Mathematical operations such as: add (+), abstract (-), multiplier (×), divide (÷). 

• Logical operations: this is basic to account comparisons to choose true or false specific  case, 

such as >,< ,>=,<=,<>,= as a result of these comparisons specific instructions may be 

executable.   

• Merge number of simple comparisons by specific tools such as: AND, OR, NOT. 

 

Q11/ Computer has one or more disk drives: devices that store information on a metal or plastic 

disk. The disk preserves the information even when your computer is turned off. Describe 

Storage Unit. 

Storage Units 

Your computer has one or more disk drives—devices that store information on a metal or 

plastic disk. The disk preserves the information even when your computer is turned off.  

• Hard disk drive 

Your computer's hard disk drive stores information on a hard disk—a rigid platter or stack of 

platters with a magnetic surface. Because hard disks can hold massive amounts of  information, 

they usually serve as your computer's primary means of storage, holding almost all of your 

programs and files. The hard disk drive is normally located inside the system unit. 

 

• CD and DVD drives 

Nearly all computers today come equipped with a CD or DVD drive, usually located on the 

front of the system unit. CD drives use lasers to read (retrieve) data from a CD; many CD drives 

can also write (record) data onto CDs. If you have a recordable disk drive, you can store copies 

of your files on blank CDs. You can also use a CD drive to play music CDs on your 

computer.CD storage capacity less than 1GB. 

DVD drives (Digital Video Disk ) can do everything that CD drives can, plus read DVDs. If 

you have a DVD drive, you can watch movies on your computer. Many DVD drives can record 

data onto blank DVDs.DVD storage capacity may be 17 GB. 

 

• Floppy disk drive  

Floppy disk drives store information on floppy disks, also called floppies or diskettes. 

Compared to CDs and DVDs, floppy disks can store only a small amount of data. They also 

retrieve information more slowly and are more prone to damage. For these reasons, floppy disk 

drives are less popular than they used to be, although some computers still include them. Why 

are these disks called "floppy" disks? The outside is made of hard plastic, but that's just the 



sleeve. The disk inside is made of a thin, flexible vinyl material. Floppy disk storage capacity 

between 360 KB and 1.44 MB. 

 

Q12/ Describe Screen Element in MS Word in detail. (Word) 

 

Screen Element in MS Word 

 

1. File Tab: The File tab will bring you into the Backstage View. The Backstage View is 

where you manage your files and the data about them – creating, opening, printing, saving, 

inspecting for hidden metadata or personal information, and setting options.    

2. Ribbon: An area across the top of the screen that makes almost all the capabilities of Word 

available in a single area.   

3. Tabs: An area on the Ribbon that contains buttons that are organized in groups. The default 

tabs are Home, Insert, Design, Page Layout, References, Mailings, Review, View and EndNote 

X7.  

4. Title Bar: A horizontal bar at the top of an active document. This bar displays the name of 

the document and application. At the right end of the Title Bar is the Minimize, Maximize and 

Close buttons. 

5. Groups: A group of buttons on a tab that are exposed and easily accessible. 

6. Dialog Box Launcher: A button in the corner of a group that launches a dialog box 

containing all the options within that group. 

7. Status Bar: A horizontal bar at the bottom of an active window that gives details about the 

document. 

8. View Toolbar: A toolbar that enables, adjusts, and displays different views of a document. 

9. Zoom Button: A button that magnifies or reduces the contents in the document  window. 

10. Quick Access Toolbar: A customizable toolbar at the top of an active document. By  

default the Quick Access Toolbar displays the Save, Undo, and Repeat buttons and is used for 

easy access to frequently used commands. To customize this toolbar, click on the dropdown 

arrow and select the commands you want to add. 

 

Q13/ What the action from the following commands: ( New, Different Views, deleting text, 

Formatting a Paragraph, Previewing and Printing a Document) (Word) 

 

To Create a New Word Document:  

1) Click the File tab 

2) Click New 

3) Click Blank Document 

 

To Display Different Views: 



1) Click the View tab 

2) Click on the desired view 

View Options:  

 Read Mode: Displays as much of the content of the document as will fit in the screen 

 Print Layout View: Shows a document as it appears on a printed page 

 Web Layout View: Shows a document as it appears in a web browser 

 Outline View: Shows the structure of a document, which consist of heading and body  

text 

 Draft View: Displays the content of a document with a basic layout 

 

Deleting Text 

When deleting text in your document you can either use the Delete key or the Backspace key.  

The Delete key deletes text to the right of your cursor while the Backspace key deletes text to 

the left of your cursor. 

 

Formatting a Paragraph 

A paragraph is a select group of text that can have its own formatting characteristics, such as 

alignment, spacing and styles. 

  

1) Select the desired paragraph(s) that you want to format 

2) Choose commands from the Paragraph group on the Home tab 

3) For additional formatting options, click on the Dialog Box Launcher in the lower-right  

corner of the group to launch the Paragraph dialog box 

4) You can also use the MiniToolbar 

 

Previewing and Printing a Document 

1) Click the File tab 

2) Click Print 

 

Q14/  What are the main Placeholders in MS power point window? (Power Point) 

Slides contain placeholders ,which are areas on the slide that are enclosed by dotted borders. 

Placeholders can contain many different items, including text, pictures, and charts. Some 

placeholders have placeholder text ,or text that you can replace. They also have thumbnail-

sized icons that represent specific commands such as Insert Picture, Insert Chart, and Insert 

ClipArt. In PowerPoint, however each icon to see the type of content you can insert in a 

placeholder.  



 
 

Q15/  What mean by the selected cell is called Active Cell? Explain that (Excel ) 

Note: the selected cell is called Active Cell   

Each cell has its own name, or cell address, based on its column and row. In this example, the 

selected cell intersects column C and row 5, so the cell address is C5. The cell address will also 

appear in the Name box. Note that a cell's column and row headings are highlighted when the 

cell is selected. 

 
 

Q16/What do you mean by cell address? how can Working with Sheets tab (Excel )     

 

The cell address of an Excel sheet refers to the address that is obtained by the combination of the Row number 

and the Column alphabet. Each cell of an MS Excel sheet will have a distinct cell address.  

 

A  worksheet is a collection of cells where you keep and manipulate the data. By default, each 

Excel workbook contains three worksheets. 

Select a Worksheet 

When you open Excel ,Excel automatically selects Sheet1 for you. The name of the worksheet  

appears on its sheet tab at the bottom of the document window. 

To select one of the other two worksheets, simply click on the sheet tab of Sheet2 or Sheet3. 

  



Rename a Worksheet 

By default, the worksheets are named Sheet1, Sheet2  and Sheet3. To give a worksheet a more specific name, 

execute the following steps .  

1. Right click on the sheet tab of Sheet1. 

2. Choose Rename. 

3.  For example, type Sales 2013 

Insert a Worksheet 

You can insert as many worksheets as you want. To quickly insert a new worksheet ,click the Insert  Worksheet 

tab at the bottom of the document window. 

Move a Worksheet  

To move a worksheet, click on the sheet tab of the worksheet you want to move and drag it into the new 

position .  

1 . For example, click on the sheet tab of Sheet4 and drag it before Sheet2.  

 

Delete a Worksheet  

To delete a worksheet, right click on a sheet tab and choose Delete. 

1. For example, delete Sheet4, Sheet2 and Sheet3. 

 

Copy a Worksheet 

Imagine, you have got the sales for 2013 ready and  want to create the exact same sheet for 2011, but with 

different data. You can recreate the worksheet, but this is time-consuming. It's a lot easier to copy the entire 

worksheet and only change the numbers.  

1. Right click on the sheet tab of Sales 2013. 

2. Choose Move or Copy... 

3.  Select (move to end) and check Create a copy. 

4.  Click OK. 

 

 

 

Q17/ What are the main Placeholders in MS power point window? (Power Point)      

 

Slides contain placeholders ,which are areas on the slide that are enclosed by dotted borders. Placeholders can 

contain many different items, including text, pictures, and charts. Some placeholders have placeholder text ,or 

text that you can replace. They also have thumbnail-sized icons that represent specific commands such as 

Insert Picture, Insert Chart, and Insert ClipArt. In PowerPoint, however each icon to see the type of content you 

can insert in a placeholder.  



 
 

Q18/What are the main parts of MS power point window? How can working with different views in 

PowerPoint? (power point)  

 

Overview Pane- appears on the right side of the program windows and has to tabs 

 

Notes Pane: appears below the slide pane and provides a place for entering notes about the  current slides (e.g, 

speaker notes) 

 These notes do not appear on the screen when the slides are shown in full screen mode  

 You can print notes along with your slides to creat a set of notes pages to which you can refer during your 

presentation. 

 

Slide tape 

 Main section in PowerPoint program  

 Shows the current slide as it will appear in a presentation 

 Displays a large image of the active slide in PowerPoint 

 In this section you can edit the slide constants  

 Display one slide at a time 

 

Working in Different Views  

 Normal View-Default View-you can add graphics to your slides as well as type, edit and format text. Add 

Animation; Edit Objects  

 Slide Sorter-Displays Multiple Slides-you can perform tasks such as reordering slides and adding builds, 

transitions, and slide timings for electronic presentations. -Slide Transitions; Hide slides. 

 

 Notes Pages View-You can create pages to print and use as a guide during your presentation.  

 Reading View-In this new view, the status bar contains the Next and Previous buttons, which  are used to 

navigate quickly throughout the presentation, and the Menu button, which is used to print, copy, and edit slides. 

You can change your views under the View tab,  in the Presentation Views group. 

 

 

 



Q19/  Explain Computers Operations      (13 Marks) 
Computers Operations  

All computers execute three basic operations: 

1. Input data and instruction by input unit.  

2. Save and process data and instruction by memory unit and central processing unit. 

3. Output results and instruction by output unit.  

 

 
Q20/  What is the screen elements of Microsoft Word? explain it   
 

 

1. File Tab: The File tab will bring you into the Backstage View. The Backstage View is 
where you manage your files and the data about them – creating, opening, printing, 
saving, inspecting for hidden metadata or personal information, and setting options.    
2. Ribbon: An area across the top of the screen that makes almost all the capabilities of 
Word available in a single area.   
3. Tabs: An area on the Ribbon that contains buttons that are organized in groups. The 
default tabs are Home, Insert, Design, Page Layout, References, Mailings, Review, 
View and EndNote X7.  
4. Title Bar: A horizontal bar at the top of an active document. This bar displays the 
name of the document and application. At the right end of the Title Bar is the Minimize, 
Maximize and Close buttons. 
5. Groups: A group of buttons on a tab that are exposed and easily accessible. 
6. Dialog Box Launcher: A button in the corner of a group that launches a dialog box  
containing all the options within that group. 
7. Status Bar: A horizontal bar at the bottom of an active window that gives details about  
the document. 
8. View Toolbar: A toolbar that enables, adjusts, and displays different views of a  
document. 
9. Zoom Button: A button that magnifies or reduces the contents in the document  
window. 
10. Quick Access Toolbar: A customizable toolbar at the top of an active document. By  
default the Quick Access Toolbar displays the Save, Undo, and Repeat buttons and is 
used for easy access to frequently used commands. To customize this toolbar, click on 
the dropdown arrow and select the commands you want to add. 
 

 
Q21/  What the steps of the following:  



• Selecting Text ( in the many way) 
a) Select a word: Click and drag or double-click on the word 
b) Select a sentence: Click and drag or click in the sentence while holding down the CTRL key 

c) Select a paragraph: Click and drag or triple-click in the paragraph or double-click in the selection 
area to the left of the paragraph 

d) Select a block of text: Click and drag or click to the left of the first word, hold down the SHIFT 
key, and then immediately click to the right of the last word 

e) Select a line: Click and drag or click in the selection to the left of the line 
f) Select an entire document: Triple-click in the selection area or hit the CTRL + A keys 
g) Undo an action: On the Quick Access Toolbar click the Undo key   

 

• Font Changes 
1) Select the desired text that you want to format 

2) Choose commands from the Font group on the Home tab 

3) For additional formatting options, click on the Dialog Box Launcher in the lower-right  corner of 

the group to launch the Font dialog box 

 

• Saving and Closing a New Document 
To Save a New Document  
1) On the Quick Access Toolbar, click the Save button  

~OR~  
 
2) Click the File tab 

3) Click Save As, the Save As dialog box will appear  

4) In the File Name field, type the name of the document 

5) Click Save 

   
To Close a Document 
1) Click the File tab, and then click Close 

2) If a Microsoft Office Word dialog box appears displaying a “Do you want to save…?” message 

3) Click Save to save, Don’t Save to discard changes, or Cancel to close the dialog box  
 

 


