Microsoft Excel

 Microsoft Excel: Microsoft Excel 2010 is a spreadsheet program that is used to manage, analyze, and present data, it includes many powerful tools that can be used to organize and manipulate large amounts of data, perform complex calculations, create professional-looking charts, enhance the appearance of worksheets and more…

-Microsoft Excel is a spreadsheet tool capable of performing calculations, analyzing data and integrating information from different programs.

· By default, documents saved in Excel 2010 are saved with the .xlsx extension.

You can use Microsoft Excel to do so many things, depending upon your interest and your needs. (Calendar, Timelines, Flowcharts, Managing lists and Graphs)

Starting M. Excel 2010:
There are multiple ways to start excel, you can start excel 2010 from the start menu or by opening an existing excel file.
· When Excel starts, it creates a new blank workbook, called Book 1. The Workbook is similar to a notebook. Inside you have sheets, each of which is called a worksheet. Each worksheet has a name that appears on a sheet tab at the bottom of the workbook.

[image: ] Components of Microsoft Excel 2010:










   Workbooks and Worksheets
    Each Excel file is a Workbook containing one or more Worksheets, Default setting provides you with three worksheets, you can add or remove as needed from there.

· Worksheets can also be reordered within the file and renamed; you can also copy or move a worksheet to another workbook (file).

Title bar
The Title bar contains the name of the program Microsoft Excel, and the default name of the workbook (Excel file) Book 1 that would change as soon as you save your file and give another name.
The Ribbon:
Extends across the top of the program window, directly below the Title bar, and consists of a set of tabs, each of which contains groups of related commands. 

There are three basic components to the Ribbon: 
1. Tabs: There are seven of them across the top. Each represents core tasks you do in Excel. 
2. Groups: Each tab has groups that show related items together. 
3. Commands: A command is a button, a box to enter information, or a menu. 
· The principal commands in Excel are gathered on the first tab, the Home tab. The commands on this tab are those that Microsoft has identified as the most commonly used when people do basic tasks with worksheets, for example, the Paste, Cut, and Copy commands are arranged first on the Home tab.

· When you see the arrow (called the Dialog Box Launcher) in the lower-right corner of a group, there are more options available for the group. Click the arrow, and you'll see a dialog box or a task pane.
Row: The horizontal boxes in the worksheet, named by using numbers.
Available rows: 1 through 1,048,576 

Column: The vertical boxes in the worksheet; named by using letters of the alphabet. The first 26 are named A-Z, column 27 is named using AA… 

Available Columns: A through XFD – 16,384 columns 

Cell: Each individual box in the worksheet; named by using the grid location (A1 refers to the cell that is in Column A, Row 1).

· A cell is the intersection of a column letter and a row number. The cell address can be found in the Name Box just above column A.
· There are over 17 billion cells in each worksheet!!!! 

Name Box: Appears on the left side of the formula bar and displays the active cell address or the name of the selected cell, range, or object.







[image: ]Home Tab:



· Font: (drop-down menu) Times New Roman, Verdana, Arial, Calibri etc. 
· [image: ]Font Size: (drop-down menu) 
· [image: ][image: ]Text formatting 
· Font Color        choose Font color (drop-down menu)
· [image: ]Text alignment:
[image: ]    Horizontal alignment:                           top, middle or the bottom of the cell 
[image: ]   Vertical alignment:                                 Align Left, Center, Align Right, Justify
[image: ]            Merge and center: to merge the selected cell range and center the content 
[image: ]              Orientation: for setting the direction of the content in a cell. 
[image: ]           Wrap Text: wraps text within cells width in order to make it visible contain the text within the cell and ensure visibility when next cell (horizontally) is not empty. 
[image: ]                            Number Format: set the number format in which numbers will be displayed.
[image: ]                     Increase / decrease number of decimal places displayed.
                         Insert tool for inserting cells, columns, rows, worksheets.                
[image: ][image: ]                       Delete tool for deleting cell content and/or cell formatting; deleting columns, rows, worksheets. 
                             Format tool for formatting selected cells, columns, rows, worksheets.
[image: ]
Mouse Pointers in Excel 


1- Select – main mouse pointer used for selecting cells. Click once in a cell to select it or click and drag to select several cells. 
[image: ]2- Fill - appears after you have selected a cell (or cells) and will show only at the bottom right of the selection (tiny box called the Fill Handle). Using this will allow you to fill a series such as Monday, Tuesday, Wednesday, etc. 


3- Insertion point - appears when you are typing or have double-clicked in a cell. The flashing insertion point determines where new text and numbers appear. 
4- Column/Row selector - appears when you are over a column or row, allowing you to click once to select the entire column or row 
5- Resize - appears when you are between columns or rows, allowing you to resize them 
Selecting Rows or Columns :   
· To select one column (e.g. column A), click on the A (above the cells) the entire column shows selected. 
· To select one row (e.g. row 1), click on the 1 (to the left of the cells) the entire row is selected. 
· To select multiple columns click the letter for one column and drag right or left to include other columns. 
· To select multiple rows click the number for one row and drag down or up to include other rows.
Mini Toolbar:
Whenever text is selected within excel a small formatting toolbar will appear above the highlighted text it will disappear if the mouse cursor is moved away from the toolbar and will reappear when the mouse cursor is moved over the highlighted text again
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Formula Bar
Appears below the Ribbon and displays the data or formula stored in the active cell. It can also be used to enter or edit a formula. a function, or data in a cell. 
· The construction of Formula and functions can be seen in this bar even when the cell containing the formula is showing a calculated value.
· The fx button on the left of the bar is a tool to create functions and formula.  

Formula: The mathematical command that you want to occur within the cell. Always begins with an = sign.  

Searching for Functions : 
[image: ]To search for functions, click on the cell you want to add the function to, go to the Formulas tab, and select Insert Function:






Worksheet: Consists of a large number of cells arranged in columns and rows that form a table.

Cell Address: Column letter and row number on a worksheet, e.g. A1, C7, and F25 

Freezing Rows or Columns 
When you need to keep the top row or left column in view as you work with a large amount of data, you can Freeze it so it’s always visible on the screen.
· Note: this does not affect printing. 

1. Go to View/Freeze Panes 
2. Select either Freeze Top Row (freezes row 1) or Freeze First Column (freezes column A) 
To unfreeze, select Unfreeze Panes 
Changing Column Widths
[image: ]To adjust the width between two columns place the mouse pointer on the line between the column headers (E, F). When the pointer changes to a two-headed arrow double-click and Excel will automatically fit the column to the contents of the cell. 



Inserting Rows or Columns
[image: ][image: ]To insert a row or column: Right click in a cell to activate the context menu and choose Insert. A context menu opens asking if you would like to insert an entire row or column. 


OR

Click the row or column header, then click the Insert list arrow in the group Cells on the Home tab. Upon choosing the desire command, Excel inserts new columns to the left of the selection and new rows above.
Key Tips 
Key Tips appear whenever you press the Alt key. You can use Key Tips to perform just about any action in Excel, without ever having to use the mouse.
 1. Press ALT to make the Key Tips appear. 
[bookmark: _GoBack]2. Then press H to select the Home tab. 
[image: ]3. Press A, then C in the Alignment group to center the selected text. 


Selecting the entire worksheet 
[image: ]• To select the entire worksheet, click on the intersection between the column and row referencing numbers.





Modifying column widths 
Select a column, such as the Sales 2004 column. Right click over the selected column and from the popup menu displayed select the Column Width command. 
[image: ]

[image: ]The Column Width dialog box is displayed which allows you to set the column width. Click on the Cancel button to close the dialog box. 



Modifying row heights 
[image: ]Select one or more rows and then right click over the selected row(s). From the popup menu displayed select the Row Height command. 









[image: ]The Row Height dialog is displayed allowing you to set the exact row height, as required. 


Comments: Allows you to view a comment, similar to a sticky note in a cell. 
· The comment will not show up on the cell, but a small red triangle will appear so that you know a comment exists for that cell. To see the comment, just move your mouse over that cell. 
· (To create a comment, click insert, comment.)

Clear Cell Contents or Formats :
You can clear cells to remove the cell contents (formulas and data), formats (including number formats, conditional formats, and borders), and any attached comments. The cleared cells remain as blank or unformatted cells on the worksheet. 
1. Select the cells, rows, or columns that you want to clear. 
· Note To cancel a selection of rows or columns, click any cell on the worksheet. 
2. In the Edit group, point to Clear, and then do one of the following: 
a. To clear everything that is contained in the selected cells, click All. 
b. To clear only the formats that are applied to the cells, click Formats. 
c. To clear only the contents, leaving any formats and comments in place, click Contents. 
d. To clear any comments that are attached to the selected cells, click Comments. 

Clearing an Entire Worksheet:
To clear the worksheet, select the worksheet by clicking on the rectangle in the upper corner of the worksheet between Column Title (A) and Row Title (1).
Click the Clear list arrow on the Home tab to Clear All, Clear Formats, ……
· If you click a cell and then press DELETE or BACKSPACE, Excel clears the cell contents but does not remove comments or cell formats. 
· If you clear a cell, the value of the cleared cell is 0 (zero), and a formula that refers to that cell receives a value of 0.

Formatting is the process of changing the appearance of your workbook, a properly formatted workbook can be easier to read, appear more professional, and help draw attention to important points. The Home tab is where you will find bold, underline, highlight, etc. Practice formatting in the worksheet you have just created.






Copy and paste specific cell contents
[bookmark: __top]You can copy and paste specific cell contents or attributes (such as formulas, formats, or comments) by using the Paste Special command. Attributes other than what you select are excluded when you paste.
1. Select the cells that contain the data or other attributes that you want to copy.
2. On the Standard toolbar, click Copy[image: Copy button].
3. Click the first cell in the area where you want to paste what you copied.
4. [image: ]On the Home tab, under Edit, click Paste, and then click Paste Special.

5. On the Paste Special dialog, under Paste, do any of the following:
	All
	Paste all cell contents and formatting, including linked data.

	Formulas
	Paste only the formulas as entered in the formula bar.

	Values
	Paste only the values as displayed in the cells.

	Formats
	Paste only cell formatting.

	Comments
	Paste only comments attached to the cell.

	Paste link
	Link the pasted data to the original data. When you paste a link to the data that you copied, Excel enters an absolute reference to the copied cell or range of cells in the new location.



Cell border formatting 
[image: ]Select the range . Click on the down arrow next to the Border icon. 



[image: ]A drop down list is displayed from which you can select the required border. Select All Borders. 












[image: ]Your data will now look like this. 




To Encrypt your file and Set a Password to Open It: 
[image: ]Click the Microsoft Office File Button, click on Protect Workbook, and then click on Encrypt with Password.










· Once the Encrypt with Password dialog box appears, type a password in the 
Password box and then click OK. 
· You may use up to 255 characters for your password. 
· Next the Confirm Password dialog box will popup once you click on OK 
· [image: ]Next, in the Reenter password box, type that same password again; and then click OK to complete the encryption process in excel before saving and closing the file. 




- To save the password, choose Save As and then name the file. 
Normal View: This is the best layout to use when working with the spread sheets.
Page Layout view: In Page Layout view there are page margins at the top, sides, and bottom of the worksheet, and a bit of blue space between worksheets. Rulers at the top and side help you adjust margins
Page break Preview: Allows you to see dotted lines showing where the page breaks will occur. 

Sort: Used to sort the column/row alphabetically (from A-Z or from Z-A) or numerically (ascending or descending order). 
Filter: Allows you to “filter” out your data, so you only see selected items. 
Searching for Functions
Excel comes equipped with a great many functions, many more than the average user will ever have need of. 
Excel’s vast library of functions comes with a handy tool for searching for the best function for what you want to do. To search for functions, click on the cell you want to add the function to, go to the “Formulas” tab, and select “Insert Function”

[image: ]







In the window that pops up, type what you want to do, and click “Go”. Excel will search through its database of functions and suggest several to you, look through them, select the function whose description best matches what you wish to do, and click “OK” to insert the function into the cell you selected.
[image: ]





Sum
[image: ]As its name suggests, the SUM function adds all the selected cells together. 

Average 
[image: ]The AVERAGE function in effect adds the values of the selected cells and divides by the number of cells selected. This function is the same thing as finding the Mean of the data. 

Formulas and functions in Microsoft Excel 
SUM : Used to calculate the sum of a range of cells.
AVERAGE: The average of a group of numerical cells contents.
MIN: Minimum value among a group of values. 
MAX: Maximum value among a group of values. 
COUNT : Number of cells in the range that contains numbers.
COUNTA : Number of cells in the range that contains numbers, text , any data.
IF: Returns true if the logical test is true otherwise returns false. Logical tests are < , > , =< , => , = and <> . 
Writing Basic Formulas 
1. Date and Time 
a. Click on cell A1 
b. Select the function category: Date & Time 
c. Select the function name: Today and press OK.
 The current date will always be updated into this cell. 



2. Math 
Product (multiplies the numbers in a series) 
i. Click on cell F4 
ii. Press the equal sign 
iii. Select the function category: Math & Trig 
iv. Select the function name: Product and press OK 
v. Type B4:E4 in the Number 1 box and press OK 
3- Statistical
Average (calculates the average of a series) 
1. Click on cell F2 
2. Press the equal sign 
3. Select the function category: Statistical 
4. Select the function name: Average and press OK 
4- Logical
IF(performs a function IF certain conditions exist) 
i. Click on cell C1 in the Averages worksheet. 
ii. Press the equal sign 
iii. Select the function category: Logical 
iv. Select the function name: IF and press OK 
V. In the top box type: C2>2000 
Vi. In the middle box type: “YES” 
Vii. In the bottom box type: “NO” and press OK 
Note: You must type the quotation marks if you are using text. 
· If you know the formula, you do not have to use the formula bar. To enter a formula without the formula bar, just type: 
	Function 
	Formula
	What it Does 

	Sum
	=sum(A1:A5) 
	Finds the sum of the data in cells A1 through A5.

	
	=sum(A1,A5) 
	Finds the sum of the data in cell A1 and A5. 

	
	=sum(A1:A5,B2) 
	Finds the sum of the data in cells A1 through A5 AND cell B2. 



	Function 
	Formula
	What it Does 

	Average 	
	
	=average(A1:A5) 
	Finds the average of the data in cells A1 through A5. 

	
	=average(A1,A5) 
	Finds the average of the data in cells A1 and A5. 

	
	=average(A1:A5,B2)
	Finds the average of the data in cells A1 through A5 AND cell B2. 
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